nyoj fibonacci数列(二) 148 (矩阵快速幂模板)
  p8HP3LNVXcon 2023年11月02日 19 0


fibonacci数列(二)



1000 ms | 内存限制: 65535



3




In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

nyoj fibonacci数列(二) 148 (矩阵快速幂模板)_#define

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint


As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

nyoj fibonacci数列(二) 148 (矩阵快速幂模板)_#define_02

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

nyoj fibonacci数列(二) 148 (矩阵快速幂模板)_#define_03

. The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

输出 For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000). 样例输入

091000000000-1

样例输出


0346875


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#define ll long long
#define M 10000
#define N 2
using namespace std;
struct mat
{
	ll m[N][N];
};
mat A=
{
	1,1,
	1,0
};
mat I=
{
	1,0,
	0,1
};
mat multi(mat a,mat b)
{
	mat c;
	for(int i=0;i<N;i++)
	{
		for(int j=0;j<N;j++)
		{
			c.m[i][j]=0;
			for(int k=0;k<N;k++)
				c.m[i][j]+=a.m[i][k]*b.m[k][j]%M;
			c.m[i][j]%=M;
		}
	}
	return c;
}
mat power(mat A,int k)//矩阵快速幂 
{
	mat ans=I,p=A;
	while(k)
	{
		if(k&1)
		{
			ans=multi(ans,p);
			k--;
		}
		k>>=1;
		p=multi(p,p);
	}
	return ans;
}
int main()
{
	int n;
	while(scanf("%d",&n)&&n!=-1)
	{
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		mat ans=power(A,n-1);
		printf("%lld\n",ans.m[0][0]);
	}
	return 0;
}



【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月08日 0

暂无评论

p8HP3LNVXcon
最新推荐 更多

2024-05-31