2678 - Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, anda positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of thesubsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

Many test cases will be given. For each test case the program has to read the numbers N and S,separated by an interval, from the first line. The numbers of the sequence are given in the second lineof the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.

Sample Input

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define N 100010
#define ll long long
using namespace std;
int a[N];
int b[N];
int main()
{
	int n,s,i,j,k;
	while(scanf("%d%d",&n,&s)!=EOF)
	{			
		b[0]=0;
		for(i=1;i<=n;i++)
		{ 
			scanf("%d",&a[i]);
			b[i]=b[i-1]+a[i];
		} 
		int ans=n+1;
		i=1;
		for(j=1;j<=n;j++)
		{
			if(b[i-1]>b[j]-s)
				continue;
			while(b[i]<=b[j]-s)
				i++;
			ans=min(ans,j-i+1);
		}
		printf("%d\n",ans==n+1?0:ans);
	}
	return 0;
}