3708 - Graveyard

Programming contests became so popular in the year 2397 that the governor of New Earck — thelargest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM)at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famouscontestants placed equidistantly along the park perimeter. The alley has to be renewed from time totime when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM,but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believethe holograms are holding dead people souls, and thus always try to renew the ACM with minimalpossible movements of existing statues (besides, the holographic equipment is very heavy). Statues aremoved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of traveldistances of all statues. Installation of a new hologram adds no distance penalty, so choose the placesfor newcomers wisely!

Input

The input file contains several test cases, each of them consists of a a line that contains two integernumbers: n — the number of holographic statues initially located at the ACM, and m — the numberof statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeteris exactly 10 000 feet.

Output

For each test case, write to the output a line with a single real number — the minimal sum of traveldistances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.Note:Pictures show the first three examples. Marked circles denote original statues, empty circles denotenew equidistant places, arrows denote movement plans for existing statues.

Sample Input

2 1

2 3

3 1

10 10

Sample Output

1666.6667

1000.0

1666.6667

0.0

#include<stdio.h>
#include<string.h>
#include<math.h> 
#include<algorithm>
#define ll long long
#define N 10010
using namespace std;
int main()
{
	int n,m,i,j,k;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		double ans=0.0;
		for(i=1;i<n;i++)
		{
			double p=(double)i/n*(n+m);
			ans+=fabs(p-floor(p+0.5))/(n+m);
		}
		printf("%.4lf\n",ans*10000);
	} 
	return 0;
}