ACDREAM 03C Robbers(贪心专场)
  qvce4elbFrsc 2023年11月02日 44 0


ACDREAM 03C Robbers

Problem Description

N robbers have robbed the bank. As the result of their crime they chanced to get M golden coins. Before the robbery the band has made an agreement that after the robbery i-th gangster would get Xi/Y of all money gained. However, it turned out that M may be not divisible by Y.

The problem which now should be solved by robbers is what to do with the coins. They would like to share them fairly. Let us suppose that i-th robber would get Ki coins. In this case unfairness of this fact is |Xi/Y - Ki/M|. The total unfairness is the sum of all particular unfairnesses. Your task as the leader of the gang is to spread money among robbers in such a way that the total unfairness is minimized.
Input
The first line of the input file contains numbers N, M and Y (1 ≤ N ≤ 1000, 1 ≤ M, Y ≤ 10000). N integer numbers follow - Xi (1 ≤ Xi ≤ 10000, sum of all Xi is Y).
Output
Output N integer numbers - Ki (sum of all Ki must be M), so that the total unfairness is minimal.
Sample Input

3 10 4
1 1 2

Sample Output

2 3 5

|Xi/Y−Ki/M|, 要求求出使这个式子的值的和最小的N个k的值(k的和要为M)。

|Xi/Y−Ki/M|转换成s[i]=(M∗Xi)/Y, 最后将s[i]相加得出sum,比较sum与M的大小,作出相应操作(具体见代码)。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#define N 1005
using namespace std;
typedef long long ll;
int K[N];
double S[N];
struct rec{
    int id;
    double num;
}r[N];
int cmp1(rec a, rec b) {
    return a.num < b.num;
}
int cmp2(rec a, rec b) {
    return a.num > b.num;
};
int main() {
    int n;
    while (scanf("%d", &n) != EOF) {
        int M, Y;
        scanf("%d %d", &M, &Y);
        int X, sum = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d", &X);
            S[i] = (M * X) / Y;
            K[i] = (int)S[i];
            if (1 - (S[i] - K[i]) < S[i] - K[i]) {
                K[i]++;         
            }
            r[i].num = abs((S[i] + 1.0) / M - X * 1.0 / Y) - abs(S[i] * 1.0 / M - X * 1.0 / Y);
            r[i].id = i; 
            sum += K[i];
        }
        if (sum < M) {
            int temp = M - sum;
            sort(r, r + n, cmp1);
            for (int i = 0; i < temp; i++) {
                K[r[i].id]++;
            }
        } else if (sum > M) {
            int temp = sum - M;
            sort(r, r + n, cmp2);
            for (int i = 0; i < temp; i++) {
                K[r[i].id]--;
            }
        }
        printf("%d", K[0]);
        for (int i = 1; i < n; i++) {
            printf(" %d", K[i]);
        }
        printf("\n");
    }
    return 0;
}


【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月08日 0

暂无评论

推荐阅读
  41QlEa797qE8   2023年11月02日   36   0   0 i++c++ci
  Uw88jE728Bxt   2023年11月02日   321   0   0 #include子树ci
  vxoexqgjyiCS   2023年11月19日   17   0   0 i++linuxvim
  3n45YYmVLV9P   2023年11月13日   19   0   0 ico#includeLine
qvce4elbFrsc