poj 3253 Fence Repair 贪心
  3n45YYmVLV9P 2023年11月13日 43 0


Fence Repair


Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 34406

 

Accepted: 11071


Description


Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.


Input


Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank


Output


Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts


Sample Input


3 8 5 8


Sample Output


34


Hint


He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


Source

挑战上的,,按挑战的方法过的,比较暴力,注意ans要用long long 因为数比较大而且还要多次计算,int 会爆

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[20005];
typedef long long ll;
int swap(int &a,int &b)
{
     int temp=a;
     a=b;
     b=temp;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        ll ans=0;
        int min1=1,min2=2,t;
        sort(a+1,a+n+1);
        while(n>1)
        {
            min1=1,min2=2;
            if(a[min1]>a[min2])
               swap(min1,min2);
            for(int i=3;i<=n;i++)
                 if(a[i]<a[min1])
                 {
                      min2=min1;
                      min1=i;
                 }
                else if(a[i]<a[min2])
                 {
                     min2=i;
                 } //找出最小的数和次小的数
            t=a[min1]+a[min2];
            ans+=t;
            if(min1==n) swap(min1,min2);
            a[min1]=t;
            a[min2]=a[n]; //补足空位
            n--;
        }
        printf("%lld\n",ans);
    }
    return 0;
}




优先队列解决:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
struct Node{
    int l;
    bool operator <(Node b) const{
         return  l>b.l;
};
}node[20005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        priority_queue<Node> q;
        for(int i=1;i<=n;i++)
            {
                scanf("%d",&node[i].l);
                q.push(node[i]);
            }
        int min1,min2;
        long long ans=0;
        Node temp;
        while(q.size()>1)
        {
            min1=q.top().l;
            q.pop();
            min2=q.top().l;
            q.pop();
            temp.l=min1+min2;
            ans+=temp.l;
            q.push(temp);
        }
        printf("%lld\n",ans);
    }
    return 0;
}




【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月13日 0

暂无评论

推荐阅读
  lHsWkjQSrEp1   2023年11月13日   29   0   0 iosciscohtml
  vxoexqgjyiCS   2023年11月19日   16   0   0 i++linuxvim
  3n45YYmVLV9P   2023年11月13日   19   0   0 ico#includeLine