poj-1019-Number Sequence【思维】【规律】
  Cl8V56im8yO7 2023年11月02日 31 0


题目链接:​​点击打开链接​


Number Sequence


Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 38616

 

Accepted: 11202


Description


A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910


Input


The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)


Output


There should be one output line per test case containing the digit located in the position i.


Sample Input


2
8
3


Sample Output


2
2



思路:模拟分组,把 1 看做第 1 组,12 看做第 2 组,123 看做第 3 组……那么第 i 组就是存放数字序列为  [ 1,i ] 的正整数,但第 i 组的长度不一定是 i

已知输入查找第 n 个位的 n 的范围为 (1 ≤ n ≤ 2147483647 ),那么至少要有 31268 个组才能使得数字序列达到有第 2147483647 位

注意:2147483647 刚好是 int 的正整数最大极限值( ),所以对于 n 用 int 定义就足矣。但是 pos [ 31268 ] 存在超过 2147483647 的位数,因此要用 unsigned 或 long long 之类的去定义 pos [ ] 

其中:( int ) log10 ( i * 1.0 ) + 1 是求某个数所占的空间

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN=40000;
int n;
unsigned len[MAXN]; // 记录第 i个串的长度
unsigned pos[MAXN]; // 记录第 i个串开始位置的下标
int ans[MAXN*30]; // 记录最长的的串
int main()
{
len[1]=pos[1]=1;
for(int i=2;i<MAXN;i++)
{
len[i]=len[i-1]+(int)log10(i*1.0)+1;
pos[i]=pos[i-1]+len[i-1];
}
int cnt=1;
for(int i=1;i<MAXN;i++)
{
int bit[100];
int k=i,num=0;
while(k)
{
bit[num++]=k%10;
k/=10;
}
while(num--)
{
ans[cnt++]=bit[num];
}
}
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int i;
for(i=1;i<MAXN;i++)
{
if(pos[i]>=n)
break;
}
if(pos[i]==n)
puts("1");
else
printf("%d\n",ans[n-pos[i-1]+1]);
}
return 0;
}


【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月08日 0

暂无评论

推荐阅读
  rEZj93RghFYQ   2023年11月02日   20   0   0 i++leetcode-java
Cl8V56im8yO7
最新推荐 更多