Spreading the Wealth

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyonearound a circular table. First, everyone has converted all of their properties to coins of equal value,such that the total number of coins is divisible by the number of people in the village. Finally, eachperson gives a number of coins to the person on his right and a number coins to the person on his left,such that in the end, everyone has the same number of coins. Given the number of coins of each person,compute the minimum number of coins that must be transferred using this method so that everyonehas the same number of coins.

Input

There is a number of inputs. Each input begins with n (n < 1000001), the number of people in thevillage. n lines follow, giving the number of coins of each person in the village, in counterclockwiseorder around the table. The total number of coins will fit inside an unsigned 64 bit integer.

Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3

100

100

100

4

1

2

5

4

Sample Output

0

4

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
#define N 1000010
using namespace std;
ll a[N];
ll b[N]; 
int main()
{
	int n,i,j;
	ll m;
	while(scanf("%d",&n)!=EOF)
	{
		ll sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
			sum+=a[i];
		}
		m=sum/n;
		b[0]=0;
		for(i=1;i<n;i++)
		{
			b[i]=b[i-1]+a[i]-m;
		}
		sort(b,b+n);
		ll x=b[n/2],ans=0;
		for(i=0;i<n;i++)
			ans+=abs(x-b[i]);
		printf("%lld\n",ans);
	}
	return 0;
}