【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)
  VJeqq9jk2lCR 2023年11月19日 19 0

[COCI2006-2007#2] ABC

题面翻译

【题目描述】

三个整数分别为 【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++。这三个数字不会按照这样的顺序给你,但它们始终满足条件:【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++_02。为了看起来更加简洁明了,我们希望你可以按照给定的顺序重新排列它们。

【输入格式】

第一行包含三个正整数 【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++,不一定是按这个顺序。这三个数字都小于或等于 【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++_04。第二行包含三个大写字母 【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++_05【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++_06【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_数组_07(它们之间没有空格)表示所需的顺序。

【输出格式】

在一行中输出 【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++_05【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_i++_06【洛谷 P4414】[COCI2006-2007#2] ABC 题解(排序)_数组_07,用一个 (空格)隔开。

感谢 @smartzzh 提供的翻译

题目描述

You will be given three integers A, B and C. The numbers will not be given in that exact order, but we do know that A is less than B and B less than C. In order to make for a more pleasant viewing, we want to rearrange them in the given order.

输入格式

The first line contains three positive integers A, B and C, not necessarily in that order. All three numbers will be less than or equal to 100. The second line contains three uppercase letters 'A', 'B' and 'C' (with no spaces between them) representing the desired order.

输出格式

Output the A, B and C in the desired order on a single line, separated by single spaces.

样例 #1

样例输入 #1

1 5 3
ABC

样例输出 #1

1 3 5

样例 #2

样例输入 #2

6 4 2
CAB

样例输出 #2

6 2 4

思路

将输入数据存入数组,将数组排序后,将字母的序号作为索引访问数组。

AC代码

#include <iostream>
#include <algorithm>
#include <cctype>
#define AUTHOR "HEX9CF"
using namespace std;

int main(){
    int a[3];
    for(int i = 0; i < 3; i++){
        cin >> a[i];
    }
    sort(a, a+3);
    for(int i = 0; i < 3; i++){
    char ch;
    while(!isalpha(ch = getchar()));
    int t = (int)(ch - 'A');
    // cout << ch << endl;
    if(i){
        putchar(' ');
    }
    cout << a[t];
    }

    return 0;
}
【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月19日 0

暂无评论

推荐阅读
VJeqq9jk2lCR