UVa 350 Pseudo-Random Numbers (伪随机数的循环长度)
  OawpvTWTbKpz 2023年11月02日 44 0


350 - Pseudo-Random Numbers

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=100&page=show_problem&problem=286

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( 

 , where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for ZIM, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for ZIM, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input


7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0


Sample Output


Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220



注意:循环不一定回到开头,比如样例3中有(3111*1234+5309)%6000=(3111*5234+5309)%6000,这里循环回到了第二个数。


完整代码:


/*0.015s*/

#include<cstdio>
#include<cstring>

int father[10000];
bool vis[10000];

int main()
{
	int cas = 0, k, b, m, x, temp, count;
	while (scanf("%d%d%d%d", &k, &b, &m, &x), k || b || m || x)
	{
		memset(father, 0, sizeof(father));
		memset(vis, 0, sizeof(vis));
		vis[x] = true;
		while (true)
		{
			temp = x;
			x = (k * x + b) % m;
			father[x] = temp;
			if (vis[x]) break;
			vis[x] = true;
		}
		temp = x;
		count = 0;
		do
		{
			x = father[x];
			++count;
		}
		while (x != temp);
		printf("Case %d: %d\n", ++cas, count);
	}
	return 0;
}


但事实是循环要么回到起点,要么回到第二个数:

/*0.012s*/

#include<cstdio>

int main()
{
	int cas = 0, k, b, m, x, beg, beg2, count;
	while (scanf("%d%d%d%d", &k, &b, &m, &x), k || b || m || x)
	{
		k %= m, b %= m;
		beg = x;
		beg2 = x = (k * x + b) % m;
		count = 1;
		while (x != beg)
		{
			x = (k * x + b) % m;
			if (x == beg2) break;
			++count;
		}
		printf("Case %d: %d\n", ++cas, count);
	}
	return 0;
}





【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月08日 0

暂无评论

OawpvTWTbKpz
最新推荐 更多

2024-05-31