HDU1373 Knight Moves(DFS)
  TEZNKK3IfmPf 2023年11月13日 19 0

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13720    Accepted Submission(s): 8044

Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.

题意:下国际象棋,8*8的棋盘,马走日,求最短路径。

题解:求最短路径先想到的就是用bfs,不过我还不会就用dfs写了,马走日可以走8个方向,将棋盘数据初始化较大的值,棋盘数据记录到这个地方最小步数,如果走下一个地方,其步数大,就换另外的方向走。

具体代码如下:

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int map[8][8];
int d[2][8]={-2,-2,-1,-1,1,1,2,2,1,-1,2,-2,2,-2,1,-1};
int fi,fj;//终点
void DFS(int i,int j,int step)
{
map[i][j]=step;
if(i==fi&&j==fj)
return;
for(int k=0;k<8;k++)
{
int x=i+d[0][k];
int y=j+d[1][k];
if(x<0||x>=8||y<0||y>=8||map[x][y]<=step+1)
continue;
DFS(x,y,step+1);
}
}
int main()
{
string a,b;
while(cin>>a>>b)
{
memset(map,10000,sizeof(map));
fi=b[0]-'a';
fj=b[1]-'1';
DFS(a[0]-'a',a[1]-'1',0);
cout<<"To get from "<<a<<" to "<<b<<" takes "<<map[fi][fj]<<" knight moves."<<endl;
}
return 0;
}

 

【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月13日 0

暂无评论

TEZNKK3IfmPf