uva 350 Pseudo-Random Numbers
  qvce4elbFrsc 2023年11月02日 139 0


                      uva 350 Pseudo-Random Numbers

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating (

, where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for Z, I, M, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for Z, I, M, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input


7 5 12 4 5173 3849 3279 1511 9111 5309 6000 1234 1079 2136 9999 1237 0 0 0 0


Sample Output


Case 1: 6 Case 2: 546 Case 3: 500 Case 4: 220



题目大意:给出z、l、m、i,根据公式l = (z * l + i ) % m,问l形成的循环有多少数。

解题思路:只要注意形成的循环第一个元素不一定是原先的l,没什么难度,但是因为格式WA了两次  orz。   再一次证明了格式的重要性。

#include<stdio.h>
#include<string.h>
int main(){
	int cnt2 = 1;
	int num[100000];
	int Z, L, I, M;
	int cnt, l, flag = 0;
	while (scanf("%d %d %d %d\n", &Z, &I, &M, &L) != EOF) {
		if (Z == 0 && M == 0 && I == 0 && L == 0) {break;}
		flag = 0;
		cnt = 0;
		memset(num, 0, sizeof(num));
		num[cnt++] = L;
		for( ; ; ) {
			L = (Z * L + I) % M;
			for (int i = 0; i < cnt; i++) {
				if (L == num[i]) {
					flag = i;
					break;
				}
			}
			if (flag != 0) {
				break;
			}
			num[cnt++] = L;
		}
		printf("Case %d: %d\n", cnt2++, cnt - flag);
	}
	return 0;
}




【版权声明】本文内容来自摩杜云社区用户原创、第三方投稿、转载,内容版权归原作者所有。本网站的目的在于传递更多信息,不拥有版权,亦不承担相应法律责任。如果您发现本社区中有涉嫌抄袭的内容,欢迎发送邮件进行举报,并提供相关证据,一经查实,本社区将立刻删除涉嫌侵权内容,举报邮箱: cloudbbs@moduyun.com

  1. 分享:
最后一次编辑于 2023年11月08日 0

暂无评论